Java Installation

ezDL needs a Java SE 7 or 8 runtime enviroment (JRE).

Supported JREs: Oracle Java 7/8 (recommended), OpenJDK 7/8 (Linux only)
Unsupported JREs: Oracle Java 6, OpenJDK 6, other older versions

Windows XP/7/8/8.1

  • Download and install Java SE 7/8 JRE from http://java.com
  • If you use a 32-bit web browser then you have to install a 32-bit JRE
  • If you use a 64-bit web browser then you have to install a 64-bit JRE
  • Recommendation: Install both a 32-bit as well as a 64-bit JRE
  • Reboot computer after installation completed

Debian/Ubuntu

To install the Oracle Java (recommended):
sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer

Restart Web browser.

Only necessary if Firefox browser plugin is not working after installing Oracle Java:

ln -s /usr/lib/jvm/java-7-oracle/jre/lib/<architecture>/libnpjp2.so ~/.mozilla/plugins

Restart Web browser after installation completed.

Please visit http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html for more information.

To install the OpenJDK:

JRE:

sudo apt-get install openjdk-7-jre

Web browser plugin:

sudo apt-get install icedtea-plugin

Other Linux versions

more information is coming soon

Mac OS X

more information is coming soon

Checking if Java is already installed

Visit http://java.com/de/download/testjava.jsp to check if Java and the Java Web browser plugin have been installed succesfully.

Removing old Java versions

It is sufficient to have only the most recent version installed. Visit http://java.com/de/download/uninstall.jsp for further information about how to remove old Java versions from your computer.